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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation >Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This document is intended as supplementary material to HFSS users. We assume you have
some experience of designing projects using HFSS. The document includes instructions to cre-
ate, solve, and analyze results of models that are excited with Floquet ports.

This chapter contains the following topics:

l General Outline
l Floquet Ports in HFSS

General Outline
For the projects described in this guide, you will perform the following tasks in HFSS:

l Create the geometric models.
l Modify the models’ design parameters.
l Specify solution setup and sweep for the designs.
l Validate the design setups.
l Run HFSS simulations.
l Create 2D x-y plots of S-parameter results.

Floquet Ports in HFSS
The Floquet port in HFSS is used exclusively with planar-periodic structures. Chief examples are
planar phased arrays and frequency selective surfaces when these may be idealized as infinitely
large. The analysis of the infinite structure is then accomplished by analyzing a unit cell. Linked
boundaries most often form the side walls of a unit cell, but in addition, a boundary condition is
required to account for the infinite space above. The Floquet port is designed for this purpose.

The Floquet port is closely related to a Wave port in that a set of modes (“Floquet modes”) rep-
resents the fields on the port boundary. Fundamentally, Floquet modes are plane waves with
propagation direction set by the frequency, phasing, and geometry of the periodic structure. Just
like Wave modes, Floquet modes too have propagation constants and experience cut-off at low
frequency.

When a Floquet port is present, the HFSS solution includes a modal decomposition that gives
additional information on the performance of the radiating structure. As in the case of a Wave
port, this information is cast in the form of an S-matrix interrelating the Floquet modes. In fact, if
Floquet ports andWave ports are simultaneously present, the S-matrix will interrelate all Wave
modes and all Floquet modes in the project.

For the current version, the following restrictions apply:

l Currently, only modal projects may contain Floquet ports.
l Boundaries that are adjacent to a Floquet port must be linked boundaries.
l Fast frequency sweep is not supported. (Discrete and interpolating sweep are supported.)

Getting Started with HFSS™: Floquet Ports
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2 - Array Antenna
This chapter contains the following topics:

l Sample Project - Array Antenna
l Set Units, Options, and Solution Type
l Create Unit Cell Model
l Assign Primary and Secondary Boundaries
l Assigning Wave Port
l Assign Floquet Port

o Floquet Port Dialog Box
l Add Solution Setup
l Run Simulation and View Results
l Create Variables for Scan Angles
l Use Scan Angles for the Model
l Set Up Parametric Sweep of Scan Angle

o Set up Modes for Parametric Sweep
o Mode Selection

l View Parametric Sweep Results

Sample Project – Array Antenna
The Array Antenna figure below illustrates an infinite array of square aperture antennas in a con-
ducting plane. The elements are fed from below the plane by square waveguide ports with dom-
inant modal field aligned in the direction shown.

Array Antenna 2-1
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Figure 2-1: Array Antenna

When the elements are uniformly excited so that the array radiates in the broadside direction,
the field above the array is periodic. The relative positions of the periodic points where field val-
ues are equal may be specified by a pair of vectors, shown in blue and denoted by a and b.
These "lattice vectors" describe the geometry of the array but are independent of the nature of
the array elements themselves. The lattice vectors may be parallel-transported anywhere in the
array plane to show corresponding field points.

In the usual way, a unit cell may be analyzed to represent the entire array and the outline of one
possible unit cell is shown in the Array Antenna figure using dotted lines.

The following figure depicts an HFSSmodel for the unit cell of the infinite array. The model con-
sists of two boxes. The lower box represents the feeding waveguide and the top box is the unit
cell for the region above the plane. The dimensions and geometry of the unit cell reflect the lat-
tice vectors of the array. Linked boundaries are defined on the cell walls and aWave port
provides the array element excitation.

Array Antenna 2-2
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Figure 2-2: HFSS Model of Unit Cell with Lattice Vectors

Note:

A Floquet port is used on the (top) open boundary.

Set Units, Options, and Solution Type
Define the name, options, design type, units, and solution type for this project before you build
the model.

1. Launch Ansys Electronics Desktop and name a new project RhombicArray (by renaming
Projectx at the top of the Project Manager).

2. On the Desktop ribbon tab, click General Options.
a. In the tree on the left side of theOptions dialog box, select the 3D Modeler > Draw-

ing group.
b. Clear the Edit properties of new primitives option, if it is selected.

Array Antenna 2-3
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Figure 2-3: Options Dialog Box – 3D Modeler > Drawing Group

Note:

In other HFSS getting started guides, this option has been selected, and
you've used the pop-up Properties dialog box to edit the parameters of
newly drawn objects. For this exercise, the Properties dialog box will not
appear when you draw a new object. Instead, you will use the docked Prop-
erties window (located beneath the Project Manager by default) to edit the
properties of new objects.

c. ClickOK.

3. On the Desktop ribbon tab, click Insert HFSS design. (You do not have to access
the drop-down menu. The default menu action is to insert a conventional HFSS design.)

4. On the Draw ribbon tab, click Units, choosemeter from the Select Units drop-down
menu, and clickOK.

5. From the menu bar, click HFSS > Solution Type.

The Solution Type dialog box appears.

6. UnderOptions, selectModal and also ensure that the remaining settings are as shown in
the following image:

Array Antenna 2-4
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Figure 2-4: Solution Type Dialog Box

7. ClickOK.

Enable Legacy View Orientations
This getting started guide was created based on standard view orientations that were in effect
for version 2023 R2 and earlier of the Ansys Electronics Desktop application. For consistency
between your experience and the views and instructions contained in this guide, select the
Enable Legacy View Orientation option in the 3D UI Options dialog box, as follows:

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Select Enable Legacy View Orientation:

Array Antenna 2-5
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3. ClickOK.

Changing the view orientation option does not change the model viewpoint that was in
effect at the time.

4. On the Draw ribbon tab, click Orient to change to the Trimetric view, which is the
default legacy view orientation.

You do not have to select Trimetric from theOrient drop-down menu. The default view
appears when you clickOrient.

Although this option can only be accessed once a design is added to a project, it is a global
option. Your choice is retained for all future program sessions, projects, and design types that
use the 3D Modeler or that produce 3D plots of results.

At the end of this guide, you will be prompted to clear the Enable Legacy View Orientation
option, if you prefer to use the view orientation scheme implemented for 2024 R1 and newer ver-
sions going forward.

For a comparison of the legacy and current view orientations, search for "View Options: 3D UI
Options" in the HFSS help. Additionally, views associated with Alt + double-click zones have

Array Antenna 2-6
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been redefined. The current orientations are shown in the help topic, "Changing the Model View
with Alt+Double-Click Areas."

Create Unit Cell Model
1. On the Draw ribbon tab, click Draw box and press F3 to ensure that you are using the

graphical drawing mode.
2. Click at three different locations in the Modeler window to graphically create an arbitrary

box. Then, define the values in the Command tab of the docked Properties window, as
shown in the following figure:

Figure 2-5: Properties of Box1 – Command Tab

Do not clear the selection yet.

3. In the Attribute tab of the docked Properties window, make the following changes:
a. Ensure thatMaterial Appearance is not selected.
b. Change the Color to Blue-Gray (column 7, row 2 of color swatches; Red: 128,

Green: 128, Blue: 192).
c. Set the Transparent value to 0.8.

4. Again click Draw box on the Draw ribbon tab.
5. Create another arbitrary box. Then, define the values in the Command tab of the docked

Properties window, as shown in the following figure:

Figure 2-6: Properties of Box2 – Command Tab

6. In the Attribute tab of the docked Properties window, make the following changes:

Array Antenna 2-7

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Floquet Ports

a. Ensure thatMaterial Appearance is not selected.
b. Change the Color to Blue-Gray (column 7, row 2 of color swatches; Red: 128,

Green: 128, Blue: 192).
c. Set the Transparent value to 0.5.

7. Click in the Modeler window background to clear the selection and press Ctrl+D to fit the
view.

Figure 2-7: The Unit Cell Model

Assign Primary and Secondary Boundaries (for Array)
Assign boundaries to the Box1 object as follows:

1. Press F to start the Face selection mode.
2. Select the face on the +X side of the top box (Box1). See U Vector Drawn.
3. From the menu bar, click HFSS > Boundaries > Assign > Coupled > Primary.

The Primary Boundary dialog box appears.

Array Antenna 2-8
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Figure 2-8: Primary Boundary Dialog Box

Note:

Leave the default Name as Primary1.

4. Select New Vector from the U Vector drop-down menu.

TheMeasure Dataand Create Line dialog boxes appear.

Note:

TheMeasure Data dialog box will show up only if you have selected Show meas-
ure dialog during drawing in the 3D Modeler > Drawing group of theOptions
dialog box. You can access theOptions dialog box by pressingGeneral Options
on the Desktop ribbon tab.

5. Click (snap to) the lower-right corner of the face and then click on the lower-left corner to
draw the U vector (red arrow). The vector runs along the bottom edge of the selected face
and points from right to left (in the global -Y direction), as shown in the following image:

Array Antenna 2-9
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Figure 2-9: U Vector Drawn

Note:

Once you click the second point, the U Vector field in the Primary Boundary dia-
log box should now indicate Defined.

6. ClickOK to assign the primary boundary.
7. If the boundary visualization is not displayed, select Primary1 under Boundaries in the

Project Manager.

Your model should look like the following figure:

Figure 2-10: Primary1 Boundary Assigned

Array Antenna 2-10
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Keep the boundary selected, which will help you visualize the model orientation in the next
step.

8. While holding down the Z key, click and drag using themiddlemouse button to rotate the
model viewpoint approximately 180 degrees about the Z axis. Do this by dragging the
cursor in a semi-circular path around the screen center. A 180-degree arc will produce
180 degrees of view rotation.

If you don't have a three-button mouse, and you have Enable Legacy View Navigation
selected in your User Interface Options (which is selected by default), then: Alt + click
(using the leftmouse button) to provide the same rotational control via dragging.

Position the model for good access to the -X face of the top box, where you will next apply
the secondary boundary.

9. Select the face on the -X side of the top box.

Note:

Alternatively, without rotating the model viewpoint (step 8), you could initially
select a face in the foreground and then press B (next Behind) to select the
desired hidden face. Since you can easily select vertices behind objects, this
method won't impede the vector definition for the secondary boundary, though a
vector on the back side of the model would be less visible.

10. On the toolbar, click HFSS > Boundaries > Assign > Coupled > Secondary.

The Secondary: General Data dialog box appears.

Array Antenna 2-11
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Figure 2-11: Assigning Secondary1 Boundary to Back Face

11. Select Primary1 from the Primary Boundary drop-down menu.
12. Select New Vector from the U Vector drop-down menu.

TheMeasure Data and the Create Line dialog boxes appear.

13. Click (snap to) the lower-left corner of the selected face and then click the lower-right
corner. The U Vector runs along the bottom edge of the selected face and points in the -Y
global direction.

Note:

The U and V vector directions must be the same for the Primary and its cor-
responding Secondary.

The Secondary: General Data dialog box reappears with the U Vector now Defined.
Notice that the Reverse Direction option has been selected automatically to make the V
Vector of the Secondary boundary consistent with the direction of the corresponding
Primary boundary vector. Otherwise, the Secondary V Vector would be pointing in the
opposite direction (correct axis but wrong sign).

Note:

Leave the Name as Secondary1.

14. Click Next.

The Secondary: Phase Delay dialog box appears.

Figure 2-12: Secondary: Phase Delay Dialog Box

Array Antenna 2-12
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15. Accept the default phase delay settings and click Finish.

The Secondary1 boundary is assigned.

Figure 2-13: Secondary1 Boundary is Assigned

16. Select the -Y face of the top box (to the right side of Secondary1, as currently viewed).
Then, right-click and choose Assign Boundary > Coupled > Primary from the short-cut
menu.

The Primary Boundary dialog box appears.

17. Select New Vector from the U Vector drop-down menu.
18. Click (snap to) the lower-left corner of the selected face and then click the lower-right

corner of the same face to draw the U Vector. The vector runs along the bottom edge of
the selected face and points in the +X global direction.

Reverse direction is automatically selected.

Figure 2-14: Primary2, V Vector Pointing Up

19. ClickOK.

The boundary Primary2 is applied.

Array Antenna 2-13
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20. On the Draw ribbon tab, click Orient to restore the default Trimetric view of the model.
21. Select the +Y face of the top box (opposite side from Primary2).
22. Right-click and choose Assign Boundary > Coupled > Secondary.

The Secondary: General Data dialog box appears.

23. Choose Primary2 from the Primary Boundary drop-down menu.
24. Choose New Vector from the U Vector drop-down menu.

The Create Line andMeasure Data dialog boxes appear.

25. Click (snap to) the lower-right corner of the selected face and then click on the lower-left
corner of the face. The U Vector runs along the bottom edge of the selected face and
points in the +X global direction. Also, the V Vector is correct and does not need to be
reversed.

The Secondary: General Data dialog box reappears.

26. Click Next.

The Secondary: Phase Delay dialog box appears.

27. Accept the default phase delay settings and click Finish.

The Secondary2 boundary is assigned.

Figure 2-15: Primary2 and Secondary2 Boundaries Assigned

28. Click in the Modeler window's background area to clear the selected boundaries and face.

Array Antenna 2-14
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Direction of the U-V Vectors
HFSS uses the U and V vectors to set up a local co-ordinate system. A point on the Primary
boundary must correspond to one on the Secondary. A point on the Secondary needs to be
paired with the Primary so that a one-to-one correspondence can be established. Such a
coordinate system should be constructed and aligned properly, in the same directions, so that
the mapping is accomplished successfully. Additionally, both vectors should point into the bound-
ary face from a perimeter edge or vertex. Therefore, when the V Vector is directed downwards in
this exercise (away from the face), you must select the Reverse Direction option to keep it on
the selected boundary face of the box, and not pointing outside of it.

Assign Wave Port
HFSS offers two methods of specifying mode alignment and polarity for wave port excitations:

l Specify an integration line to either set the mode polarity or align the modes.
l Align the modes analytically using a local coordinate system based on U and V axes you
define.

When assigning a wave port, HFSS displays aWave Port: Modes dialog box with options to help
set up theMode Alignment and Polarity. A portion of this dialog box is shown below:

Figure 2-16: Portion of theWave Port: Mode Dialog Box

For this particular design (that is, a cell model with emphasis on Floquet ports), we recommend
you assign the Wave port with analytical mode alignment. Therefore, you should select the third
option underMode Alignment and Polarity for this project (as shown in the preceding figure).

Note:

For more information, search for "Wave Port" in the program help.

Assign Wave Port with Analytical Mode Alignment
You will assign a Wave Port boundary to the bottom face of the feeding waveguide for the pur-
pose of injecting energy into the array element.

1. Click near the bottom of the +X face of the bottom box. Then, press B to select the bottom
face. (SeeWave Port Assigned on Bottom Face.)

2. Right-click, and from the shortcut menu, select Assign Excitation > Port >Wave Port.

Array Antenna 2-15
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TheWave Port: General dialog box appears.

3. Make the following entries:
a. Name =Waveport
b. Number of Modes = 2

Note:

Because the feeding waveguide has a square cross-section, two wave-
guide modes must be specified.

c. Select Align Modes analytically using coordinate system option.
d. From the U Axis drop-down menu, select New Vector.

Figure 2-17: Wave Port: Modes Dialog Box

The cursor with a dotted line appears.

Array Antenna 2-16
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4. Define the U Axis as follows:
a. Click the midpoint of the -Y edge of the bottom face. A small opaque triangle

appears to indicate the midpoint snapping location.

After you click, a small local pair of mini axes appear at the midpoint, one running
along the edge and one running across the middle of the selected face.

b. Click the midpoint of the opposite (+Y) edge of the bottom face, specifying a U Axis
that is parallel to the global Y axis and also pointing in the same direction.

Figure 2-18: Defining the U Axis

5. Select Reverse V Direction so that the V Axis points in the same direction as the global X
Axis.

6. Click Next.

TheWave Port: Post Processing dialog box appears.

7. Accept the default settings and click Finish to complete the wave port assignment.
8. If the wave port visualization is not currently displayed, selectWaveport under Excitations

in the Project Manager.

Your model should look like the following figure:

Array Antenna 2-17

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Floquet Ports

Figure 2-19: Wave Port Assigned on Bottom Face

9. Clear the selection.

Assign Floquet Port
To assign the Floquet port perform the following steps.

1. Select the top face of the upper box.
2. Right-click, and select Assign Excitation > Port > Floquet Port from the shortcut menu.

The Floquet Port: General dialog box appears, and the top face is labeled as
FloquetPort1:
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Figure 2-20: Selected Face and Floquet Port: General Dialog Box

3. Under Lattice Coordinate System, select New Vector from the A Direction drop-down
menu.

The cursor with a dotted line appears on the Modeler window.

4. From the -X, -Y corner of the top face, draw the A Direction vector parallel to, and in the
same direction as, the X-axis.

The a vector is drawn and the Floquet Port: General dialog box reappears.

5. Select New Vector from the B Direction drop-down menu.
6. Draw the B Direction vector from the same -X, -Y corner, perpendicular to the a vector,

and pointing in the same direction as the +Y global axis.

Note:

The lattice vectors a and bmust have a common origin.
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Figure 2-21: Floquet Port A and B Vectors Defined

After clicking the second point, the Floquet Port: General dialog box reappears, and both
vectors now indicate Defined.

7. Click Next.

The Floquet Port: Modes Setup dialog box appears:

Figure 2-22: Floquet Port: Modes Setup Dialog Box

8. Keep the default settings and click Next.

The Floquet Port: Post Processing dialog box appears:
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Figure 2-23: Floquet Port: Post Processing Dialog Box

9. Verify that the Deembed option is not selected and click Next.

The Floquet Port: 3 D Refinement dialog box appears:

Figure 2-24: Floquet Port: 3-D Refinement

10. Accept the default settings and click Finish.

The Floquet port is assigned and FloquetPort1 appears in the Project Manager window
under Excitations:
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Figure 2-25: Floquet Port Assigned

Floquet Port Dialog Box
While assigning the Floquet Ports in this exercise, a wizard stepped you through the four phases
of setting up the port. You used the options available on the Floquet Port: General dialog box
and accepted default settings for the other three (Modes Setup, Post Processing, and 3D Refine-
ment.

If you double-click a previously defined port in the Project Manager to review or modify its set-
tings, a unified Floquet Port dialog box appears having tabs for each of the four separate
aspects of defining the port:

Figure 2-26: Floquet Port Dialog Box Tabs

The settings on theModes Setup, Post Processing, and 3D Refinement tabs are described
below.
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Floquet Port: Mode Setup

See Floquet Port: Modes Setup Dialog Box. Floquet modes are specified by two modal indices
and a polarization setting. These designations resemble the textbook notation for rectangular
waveguide modes, such as "TE10." The Floquet field patterns are different, however.

The Floquet modes in the modes table both have modal indicesm and n equal to zero. They are
sometimes called “specular” modes. In this project, the specular modes consist of two ortho-
gonally-polarized plane waves propagating normal to the plane of the array.

Specular modes are always an essential part of the Floquet mode set. However, sometimes,
due to electrical symmetry, one of the two polarizations may be omitted.

The final column of the mode table is labeled Attenuation. The attenuation of the mode is meas-
ured in the direction normal to the plane of the array.

The value given for the specular modes is 0 dB since they are propagating. Higher-order modes
will experience attenuation if they are cut off. The value of attenuation is greater than zero.

Note:

The default specular pair of modes is sufficient for this simulation.

Floquet Port: Post Processing

See Floquet Port: Post Processing Dialog Box. This tab lets you specify a de-embedding dis-
tance. Just as in a wave port, de-embedding is an optional post processing step employed when
the phase of the S-parameter elements is of interest. The interface for de-embedding a Floquet
port is the same as that for a wave port. For this example, we omit specifying any de-embedding.

Floquet Port: 3D Refinement

See Floquet Port: 3 D Refinement Dialog Box. The 3D Refinement tab controls which Floquet
modes participate in 3D adaptive mesh generation.

The default settings are such that Floquet modes will not participate in 3D adaptive refinement.

In any model with wave, lumped, or Floquet ports, there is a 3D modal field pattern associated
with each defined mode. This is the 3D field pattern corresponding to stimulation of the one
mode, with all other modes terminated with a matched impedance. The 3D mesh that is created
by HFSS on subsequent adaptive passes is actually a compromise designed to adequately rep-
resent all modal field patterns simultaneously.

When a specific modal field pattern is of interest, greater solution efficiency is achieved by adapt-
ing only on the basis of the one field pattern. In the case at hand, the modal pattern cor-
responding to excitation of the Wave port is of prime interest. Hence, the default setting of the 3D
refinement tab ignores the Floquet modal field patterns with regard to adapting the 3D mesh.
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Add Solution Setup
Add a solution setup for your model, as follows:

1. On the Simulation ribbon tab, click Setup > Advanced.

The Driven Solution Setup dialog box appears.

2. Specify the settings as shown in the following figure:

Figure 2-27: Driven Solution Setup – General Tab

3. Select the Adaptive Options tab.
4. Enter the settings as shown in the following figure:
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Figure 2-28: Driven Solution Setup – Adaptive Options Tab

5. ClickOK to accept the settings.

The Edit Frequency Sweep dialog box appears automatically when you complete the solu-
tion setup for a model that already has at least one port assigned. However, for this exer-
cise, no frequency sweep is needed.

6. Click Cancel to dismiss the dialog box without defining a sweep.

Run Simulation and View Results
Now that you have completed the entire set-up you are ready to analyze it. Before that, be sure
to save the project.

1. On the Simulation ribbon tab, click Analyze All.

The Progress Window indicates that HFSS is running the simulations. The Message Man-
ager indicates normal completion of the simulation if everything went well.

2. Under Analysis in the Project Manager, right-click Setup1 and selectMatrix Data.

The Solutions dialog box appears with theMatrix Data tab selected.

Since phase is unimportant for this case, you can show the magnitudes only.

3. Select the Format subtab and chooseMagnitude from the drop-down menu to simplify
the matrix data table. Then, return to the View subtab:
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Figure 2-29: Solutions Dialog Box – Matrix Data Tab – Magnitudes Only

There are several things to note:

l The S-matrix is a 4×4 matrix and interrelates the wave port modes with the Floquet
modes.

l The Floquet modes in the S-matrix are listed in the order specified in the Floquet
port's Mode Setup panel. You can refer to this panel while the matrix data is dis-
played by double-clicking FloquetPort1 in the Project Manager and selecting the
Modes Setup tab. By doing so, you are reminded that FloquetPort1:1 refers to
mode TE00 and FloquetPort1:2 refers to mode TM00.

l The first and second columns of the S-matrix indicate the coupling of each indi-
vidual Floquet mode excitation to the other ports and modes of the model. The phys-
ical picture of an excited Floquet mode is a plane wave incident on the infinite array
from above. For this simulation, each Floquet mode transfers most of its power
(over the Floquet port surface area) to the wave port mode with the same polar-
ization. In these cases think of the array acting in “receive mode.”

l The third column of the matrix gives the modal amplitudes for a unit stimulation of
the first mode of the Wave port (that is, the array acting in “transmit mode”). The
third entry is the magnitude of the active reflection coefficient of the unit cell. The
first and second rows give the power coupled into each of the two Floquet modes.
Virtually all the non-reflected power is coupled into the first Floquet mode, which rep-
resents a plane wave leaving the face of the array. Similarly, the fourth column con-
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tains the power transmitted to the Floquet modes in the first two rows, with the pre-
dominant amount going to the second Floquet mode.

4. Close the Solutions dialog box.

Create Variables for Scan Angles
Array antennas have the unique ability to redirect (scan) their energy without mechanical motion.
To include the effects of scanning in the HFSS simulation, this section discusses parameterizing
the simulation using scan angles.

1. On the menu bar, click Project > Project Variables.

The Properties dialog box appears.

2. In the Project Variables tab, click Add.

The Add Property dialog box appears.

3. Specify $phi_scan for the Name and specify 90deg for the Value:

Figure 2-30: Add Property Dialog Box

4. ClickOK.

The Add Property dialog box closes and the variable $phi_scan has been added to the
Project Variables tab of the Properties window.

5. Click the Add button again.
6. In the Add Property dialog box, specify $theta_scan for the Name and 0deg for the

Value.
7. ClickOK.

The Add Property dialog box closes and the variable $phi_scan has been added to the
Project Variables tab of the Properties window:
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Figure 2-31: Properties Dialog Box – Project Variables Tab

8. ClickOK.

9. It's a good time to Save your model.

Note:

When using scan angles in unit cell models, the plane of periodicity (here, the array
plane) should be parallel to the global x-y plane. Adhering to this natural convention
ensures the simplest and clearest relationship between scan angles and the structure
being modeled.

Use Scan Angles for the Model
Now that you created the scan angle variables, you will use them in the model. To do so, perform
the following steps:

1. Under Boundaries in the Project Manager, double-click Secondary1.

The Secondary dialog box appears.

2. Select the Phase Delay tab and specify the Phi and Theta Scan Angles as shown in fol-
lowing figure:
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Figure 2-32: Using Scan Angles Variables

3. ClickOK.

The scan angles are set for Secondary1 and also copied into the settings for Secondary2.

Note:

Ignore the following informational message that will appear in the Message Man-
ager window: “Solutions have been invalidated. Undo to recover.”

Set Up Parametric Sweep of Scan Angle
To illustrate more aspects of the Floquet port interface, we now seek the active reflection coef-
ficient of the array as a function of scan angle. When the scan direction is in the E-plane of the
array, the array exhibits a nice example of scan blindness at an angle of 27.5 degrees. To
demonstrate this and other phenomena, we will set up a parametric sweep to make an E-plane
scan from broadside (scan = 0) to endfire (scan = 90 degrees).

To setup a parametric analysis:

1. On the Simulation ribbon tab, select Parametric from theOptimetrics drop-down menu:

Figure 2-33: Optimetrics Drop-Down Menu – Parametric Command

The Setup Sweep Analysis dialog box appears.

2. On the Sweep Definitions tab, click Add.

The Add/Edit Sweep dialog box appears.
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3. Specify the sweep settings as shown in the left half of the following figure:

Figure 2-34: Add/Edit Sweep Dialog Box

4. Click Add >> to include the variable and its settings in the list on the right half of the dialog
box.

5. ClickOK.

The Setup Sweep Analysis dialog box now lists the $theta_scan variable and its descrip-
tion.

Figure 2-35: $theta_scan Variable Added to Sweep Analysis Setup

6. ClickGeneral to verify the settings are as in following figure:

Figure 2-36: Setup Sweep Analysis Dialog Box – General Tab

7. Select theOptions tab and ensure the settings are as shown in the following figure:
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Figure 2-37: Setup Sweep Analysis Dialog Box – Options Tab

8. ClickOK to accept the setup and close the dialog box.

Parametric Setup1 is now listed underOptimetrics in the Project Manager.

Set Up Modes for Parametric Sweep
1. Double-click FloquetPort1 under Excitations in the Project Manager.

The Floquet Port dialog box appears.

2. Select theModes Setup tab.

Note:

A pair of modes is adequate for a broadside scan. For larger scan angles, addi-
tional modes are required.

3. ClickModes Calculator.

Note:

The inputs for mode selection do not affect the model set up. Therefore, you can
vary the choices to explore different scenarios.

4. Make the following changes to the settings:
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a. Number of Modes = 10

Note:

Requesting so many modes will give you an idea which modes are neces-
sary and which are not.

b. Frequency = 299.97 MHz, which is the actual frequency of the simulation.

Note:

If the problem setup contains more than one frequency sweep, this value is
usually set to the highest frequency to detect higher-order propagating
modes.

c. Scan Angles: Phi
l Start = 90 deg
l Stop = 90 deg
l Step Size = 0 deg

d. Scan Angles: Theta
l Start = 0 deg
l Stop = 90 deg
l Step Size = 0.5 deg
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Figure 2-38: Mode Table Calculator Dialog Box

Note:

To create a set of modes that will be adequate for every scan direction in the para-
metric sweep, the scan angles of the sweep are entered in a start-stop-step
format. The entered angles are spherical polar angles of the global coordinate
system.

5. ClickOK.

The calculator closes and displays the results in the modes table:
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Figure 2-39: Floquet Port Dialog Box – Modes Setup Tab

6. Reduce the value for the Number of Modes from 10 to 4.

The table gets trimmed to only 4 modes. The reason for trimming the modes is discussed
in the next topic (Mode Selection).

7. ClickOK.
8. Right-click ParametricSetup1 underOptimetrics in the Project Manager and select Ana-

lyze.

HFSS runs the Parametric Sweep.

Note:

The parametric analysis will take some time to solve.

Mode Selection
In the previous topic, you set up modes using theModes Calculator. This topic describes the
modes table and the criteria for mode selection. The attenuation (db/length) depends on the
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scan angle you set in theModes Calculator.

Refer to the figure, Floquet Port Dialog Box –Modes Setup Tab, and note the following details
about the results:

l The original pair of specular modes, TE00 and TM00 remain at the top of the list.
l The attenuation for both TE00 and TM00 is 0 dB, meaning that these modes are propagat-
ing unattenuated in at least one scan direction among those selected in the Mode Table
Calculator.

l A second pair of modes, TE0-1 and TM0-1 are also propagating unattenuated in at least
one scan direction.

l The six remaining modes experience attenuation of 60 dB per meter (the current default
length unit) over the set of specified scan directions.

l Any Floquet modes generated within the 3D portion of the model and propagating toward
the Floquet port must be accounted for in the modes table. Since the first four listed
modes reach the Floquet port unattenuated, we have retained them.

l The remaining modes, with large non-zero attenuation, can be excluded from the table.
Eliminating unnecessary modes increases simulation efficiency and eases interpretation
of results. The next point provides a quantitative justification for the omission of the modes
with large non-zero attenuation.

l Because the length of the unit cell is 1.25 meters, any of the last six modes that are gen-
erated at the rectangular aperture experience a minimum attenuation of 1.25 * 60dB = 75
dB by the time they reach the Floquet port plane. In most simulations this is small enough
for you to neglect such modes. Hence, we have the shortened table on which the para-
metric solution was based:

Figure 2-40: Selected Modes for Parametric Analysis
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The modes list is trimmed from the bottom up, and now, only the TE00, TM00, TE0-1, and TM0-1
remain.

Note:

You can again increase the modes by entering a number greater than 4, and the addi-
tional modes will reappear in the list. However, the correct Attenuation values will not
be shown unless you return to theModes Calculator and clickOK to refresh the cal-
culations. Remember to use the minimum acceptable number of modes to ensure sim-
ulation efficiency.

View Parametric Sweep Results
Once the simulation is over, the S-matrix coefficients at various scan angles can be examined in
theMatrix Data tab of the Solutions dialog box or by creating a report (plot). Let's take a look at
the matrix data first.

Review Matrix Data:

1. Under Analysis in the Project Manager, right-click Setup1 and chooseMatrix Data from
the shortcut menu.

2. Select the Format subtab and ensure thatMagnitude is still selected in the drop-down
menu as the specified format. Then, return to the View subtab.

3. Click the elipsis button ( ... ) to the right of the Design Variation description.

The Set Design Variation dialog box appears.

4. From the $theta_scan list, select 15deg and clickOK.

Your matrix data should be similar to the following figure:
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Figure 2-41: Solutions Dialog Box – Matrix Data Tab ($theta_scan = 15 Deg)

5. Repeat step 4 several times choosing different $theta_scan values and observe the mat-
rix coefficients at each different scan angle.

Observations:
The first four rows of the last two columns indicate the relative amount of coupling
between the four Floquet port modes and the two wave port modes. For any par-
ticular scan angle, you may notice minimal coupling between a particular Floquet
port mode and both of the wave port modes (indicated by very small S-matrix val-
ues). For example, at $theta_scan = 15 deg, the coupling is minimal at the third
and fourth Floquet modes (TE0-1 and TM0-1). However, if you sample the results
at several different scan angles, you will see that all four Floquet modes produce
significant wave port coupling at some part of the scan angle range. If you had
retained any of the additional six modes that were calculated but later removed,
you'd see minimal coupling across the entire scan angle range, due to the cal-
culated 60 db/meter attenuation of the higher modes.

6. Close the Solutions dialog box.

Generate Plots:
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This section describes how to generate reflection and transmission plots. Follow the procedure
below to create a report showing the active reflection [S(Waveport:1,Waveport:1)] and trans-
mission magnitudes for the second and fourth Floquet modes (TM01 and TM0-1) plotted as a
function of the scan angle:

7. On the Results ribbon tab, access the Modal Solution Data Report drop-down

menu and click 2D.

The Report dialog box appears.

8. Specify the settings as shown in following figure:

Figure 2-42: Report Dialog Box

9. Click New Report and click Close.

S Parameter Plot 1 is displayed, which should resemble the following figure:
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Figure 2-43: S Parameter Plot 1 – Reflection and Transmission Magnitudes

Array Antenna 2-39

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Floquet Ports

Observations:
The active reflection coefficient (blue trace) shows the scan blindness condition
at 27.5 degrees. Also, note that the TM0-1mode (green trace) becomes propagat-
ing at about 30 degrees and represents the onset of a grating lobe. From 30 to 80
degrees, power is about equally split between the TM00 (red trace) and TM0-1
modes, after which the endfire condition is approached.
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3 - Frequency Selective Surface Model
This chapter contains the following topics:

l Sample Project – FSS
l Set Unit and Solution Type
l Create the Rhombic Sheet
l Transform 2D Sheet into 3D Cell Object
l Position the Rhombus Appropriately
l Create the Aperture
l Move the Aperture to the Rhomboid
l Assign Primary and Secondary Boundaries
l Assign the Perfect E-Boundary
l Assign the Floquet Ports
l Set Up the Analysis
l Add Frequency Sweep and Analyze
l Run the Simulation
l Evaluate the Results

l Phase Transmission vs. Frequency
l S-Parameters vs. Frequency
l Port Field Display for Modes

Sample Project – FSS
You can construct unit cells for frequency selective surface (FSS) simulations using linked
boundaries and two Floquet ports, with one port above the plane of the structure and the other
port under it. The applied excitations are the Floquet modes themselves, usually one or both
specular modes. As a direct result of the field solution, the reflection and transmission properties
of the FSS are cast in terms of the computed S-matrix entries interrelating the Floquet modes.

This is somewhat in contrast to the simulation setup when PMLs or radiation boundaries are
used to terminate the unit cell. In these cases, in addition to the boundary setup, one or more
incident waves are defined separately as the excitation. The transmission and reflection prop-
erties of the FSS are then automatically computed for the user as a post-processing operation
on the field solution.

We will consider a conducting screen containing a rhombic lattice of circular apertures. The lat-
tice geometry is shown below, in which a pair of lattice vectors are drawn in blue. The angle
between the lattice vectors is 60 degrees.
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Figure 3-1: The Lattice Geometry

Consider a plane wave incident normal to the screen with polarization aligned as indicated by
the red arrows in the figure. The transmission loss magnitude and phase, as a function of fre-
quency, are the quantities of interest. The frequency band is 8 to 20 GHz.
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Figure 3-2: Unit Cell for Rhombic Lattice

Set Units, Options, and Solution Type
Define the name, options, design type, units, and solution type for this project before you build
the model.

1. Launch Ansys Electronics Desktop and name a new project RhombicLatticeFSS (by
renaming Projectx at the top of the Project Manager).

2. On the Desktop ribbon tab, click General Options.
a. In the tree on the left side of theOptions dialog box, select the 3D Modeler > Draw-

ing group.
b. Deselect the Edit properties of new primitives option.
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Figure 3-3: Options Dialog Box – 3D Modeler > Drawing Group

Note:

In other HFSS getting started guides, this option has been enabled, and
you've used the pop-up Properties dialog box to edit the parameters of
newly drawn objects. For this exercise, the Properties dialog box will not
appear when you draw a new object. Instead, you will use the docked Prop-
erties window (located beneath the Project Manager by default) to edit the
properties of new objects.

3. On the Desktop ribbon tab, click Insert HFSS design. (You do not have to access
the drop-down menu. the default menu action is to insert a conventional HFSS design.)

4. On the Draw ribbon tab, click Units, choose cm from the Select Units drop-down menu,
and clickOK.

5. From the menu bar, click HFSS > Solution Type.

The Solution Type dialog box appears.

6. UnderOptions, selectModal and also ensure that the remaining settings are as shown in
the following image:
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Figure 3-4: Solution Type Dialog Box

7. ClickOK.

If you skipped the Array Antenna chapter and intend to proceed directly to the Frequency Select-
ive Surface Model, then complete the following procedure, which was covered in the earlier
chapter. Then proceed to the next topic:

l Enable Legacy View Orientations

Create the Rhombic Sheet
You will create a simple unit cell model, as shown in the figure, Unit Cell for Rhombic Lattice. All
four sides are the same length (1.73 cm each), the circular aperture diameter is 1.2 cm, and the
cell is 4 cm high. The obtuse angles are 120 degrees each, and the acute angles are 60 degrees
each. The unit cell clearly is a rhombus. You will begin by creating a rhombic sheet object, as fol-
lows:

1. On the Draw ribbon tab, click Draw line and press F3 to ensure that you are using the
graphical drawing mode.
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2. In the Modeler window, click an arbitrary starting point and then, click threemore arbitrary
points.

3. Click on the starting point to create a closed object.
4. Right-click in the Modeler window and select Done from the short-cut menu to complete

creation of an initial polyline object.

In the History Tree, you should see four CreateLine segments underModel > Lines >
Polyline1 > CreatePolyline:

Figure 3-5: History Tree after Creating Polyline1

5. In the History Tree, select the first CreateLine segment.

The line segment's properties appear in the docked Properties window beneath the Pro-
ject Manager.

6. Edit the coordinates in the Point1 and Point2 Value column to agree with the following fig-
ure:

Figure 3-6: Polyline Properties – First CreateLine Segment

Press Enter to accept each set of endpoint coordinates.

7. Repeat steps 5 and 6 for the second and third CreateLine segments, specifying the
coordinates from the following images:

Figure 3-7: Polyline Properties – Second CreateLine Segment
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Figure 3-8: Polyline Properties – Third CreateLine Segment

Note:

For each subsequent segment, you only need to edit the coordinates of Point2
because Point2 of the previous segment is also Point1 of the current segment.
You do not need to edit either point for the last segment because its Point2 is the
same as Point1 of the first segment (since this is a closed polyline object).

8. Select the last CreateLine segment in the History Tree and verify that the coordinates
match the following figure:

Figure 3-9: Polyline Properties – Fourth CreateLine Segment

9. Click in the Modeler window's background to clear the current selection and press Ctrl+D
to fit the view.

Your rhombic sheet object should look like the following figure:
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Figure 3-10: Rhombic Sheet Created

Transform 2-D Sheet into a 3D Cell Object
Before sweeping the 2D sheet into a 3D object, place a copy of it on your system clipboard to
facilitate creating the aperture object in the next procedure. Avoid using the copy and paste fea-
ture until you've pasted a copy of the sheet object into your design, so that the contents of the
clipboard won't be overwritten.

After copying the 2D sheet object (Polyline1) to the clipboard, you will sweep it along a global Z
direction vector to produce your 3D cell object.

1. UnderModel > Sheets > Unassigned in the History Tree, click Polyline1 to select it.
2. Press Ctrl+C to copy the selected sheet object to your system clipboard.

Attention: Avoid using the copy or paste feature again until you're ready to paste a copy
of the sheet object into your design, so that the contents of the clipboard won't be acci-
dentally overwritten. You will complete the pasting operation as part of the Create the
Aperture procedure, which immediately follows this procedure.

3. On the Draw ribbon tab, click Sweep Along Vector.
4. Click the global origin (snap point) to set the first point of the sweep vector.
5. Input the second point of the sweep vector using the coordinate text boxes in the status

bar, as follows:
l dx = 0
l dy = 0
l dz = 4

The Sweep Along Vector dialog box appears.

6. Select Natural from the Draft type drop-down menu, verify that the Draft angle = 0, and
then clickOK.

Figure 3-11: Sweep Along Vector Dialog Box

The properties of the 3D object are displayed in the docked Properties window.

7. In the Attribute tab of the docked Properties window, make the following changes:
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a. Change the Name from Polyline1 to RhombicCell.
b. Ensure thatMaterial Appearance is not selected.
c. Set the Transparent value at 0.6.

8. Select the Command tab of the docked Properties window and verify that your sweep set-
tings match those shown in the following figure:

Figure 3-12: SweepAlongVector Properties

9. Press Ctrl+D to fit the view.
10. Clear the current selection.

Figure 3-13: RhombicCell Created

Create the Aperture Object
In this procedure, you will paste a copy of the closed polyline sheet object that you copied to your
system clipboard during the preceding Transform 2D Sheet into a 3D Cell Object procedure. It
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will be pasted into the model at its original location, which is lying along the global XY plane. This
places it initially at the bottom of the 3D cell.

Afterward, you will Reposition the 3D Cell so that its height is bisected by the global XY plane.
That is, half of the cell height will be in the -Z half of the Cartesian coordinate system, and half
will be in the +Z half. The 2D aperture object will remain at the XY plane (Z=0). Therefore, the
aperture will be at the middle of the 3D cell's height after you accomplish the repositioning oper-
ation.

Perform the following steps to create the aperture:

1. Press Ctrl+V to paste the contents of your system clipboard into the model (previously
copied rhombic 2D sheet object). Leave the pasted object selected.

Attention: If you've inadvertently cleared or overwritten your system clipboard, you will
not be able to select, copy, and paste the original closed polyline object. CreatePolyline, in
the History Tree, will no longer be recognized as a sheet object, and you will encounter an
error message when trying to paste it. You can use the following alternative steps to pro-
duce the aperture sheet object.

Alternative Procedure:

a. Press F to begin the Face selection mode.
b. Click near the bottom edge of one of the visible vertical faces of the RhombicCell

object. The clicked side face is initially selected.
c. Press B to select the face Behind the clicked point. The bottom face should then be

selected.
d. On the Draw ribbon tab, click Surface > Create Object from Face.

A sheet object duplicating the bottom face of the cell is added to the model.

2. In the Attribute tab of the docked Properties window, make the following changes:
a. Change the Name to Aperture.
b. Ensure thatMaterial Appearance is not selected.
c. Change the Color to brown (column 2, row 5 of the color swatches; Red: 128,

Green: 64, Blue: 0).
d. Set the Transparent value at 0.

3. On the Draw ribbon tab, click Draw circle.
4. Click the center of the Aperture sheet object (a solid circle indicates the snapping point at

the shape centroid).
5. Use the coordinate text boxes in the status bar to specify the radius of the circle, as fol-

lows, and then press Enter.
l dx = 0.6
l dy = 0
l dz = 0
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The circle's details are displayed in the docked Properties window.

6. Verify that the properties within the Command tab of the docked Properties window
match the following figure:

Figure 3-14: Circle Properties – Command Tab

7. Clear the current selection.
8. UnderModel > Sheets > Unassigned in the History Tree, select Aperture and Circle1 (in

that specific order).
9. On the Draw ribbon tab, click Subtract.

The Subtract dialog box appears.

10. Verify that Aperture is in the Blank Parts list and Circle1 is under ToolParts.

Figure 3-15: Subtract Dialog Box

11. ClickOK to perform the subtraction and close the dialog box.

The circle is subtracted from the rectangle to create the aperture:
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Figure 3-16: Aperture Completed

12. Clear the selection.

Reposition the 3D Cell
1. UnderModel > Solids > vacuum in the History Tree, select RhombicCell.
2. On the Draw ribbon tab, click Move.
3. Click any arbitrary grid point or corner vertex of the RhombicCell to specify the first point of

the move vector.
4. Using the coordinate text boxes in the status bar, specify the second point of the move vec-

tor, as follows. Then press Enter.
l dX = 0
l dY = 0
l dZ = -2

The vertical elevation of the RhombicCell is reduced by 2 cm.

5. Verify that theMove Vector in the Command tab of the docked Properties window
matches the following figure:

Figure 3-17: Move Vector Properties

6. Clear the selection.

The new RhombicCell position should place half of it above the Aperture and half below:
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Figure 3-18: RhombicCell Repositioned

Note:

The combination of the rhombic shape of the model and the trimetric viewpoint
make the aperture look like a narrow ellipse. However, it is perfectly circular (as a
Top or Bottom viewpoint orientation would make apparent).

Assign Primary and Secondary Boundaries
After completing the geometry for the FSS unit cell, you can now assign the Primary and Sec-
ondary boundaries.

Since you should have already completed the primary and secondary boundary definitions for
the Antenna Array portion of this getting started guide, this time, the instructions are less explicit.
If you need help with the vector definitions or knowing when to reverse the V vector, review the
instructions on the Array Antenna > Assign Primary and Secondary Boundaries topic.

First Pair:
For this procedure, refer to the figure, Primary1 and Secondary1 Boundaries Applied.

1. Rotate the model viewpoint somewhat about the Z axis so that the faces to receive the
boundary assignments don't overlap.

2. Press F to begin the Face Selectionmode.
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3. Select the face where the Primary boundary is to be applied (labeled and shown without
the green shading in the reference figure). This face is the +X side of the RhombicCell
object.

4. Using the menu bar, click HFSS > Boundaries > Assign > Coupled > Primary.

The Primary Boundary dialog box appears.

5. Keep the Name as Primary1.
6. Define the U Vector and V Vector direction to be consistent with the reference figure.
7. ClickOK.
8. Select the face where the Secondary boundary is to be applied (the -X side of the

RhombicCell object).
9. Using the menu bar, click HFSS > Boundaries > Assign > Coupled > Secondary.
10. Keep the Name as Secondary1.
11. Choose Primary1 from the Primary Boundary drop-down menu.
12. Define the U Vector and V Vector direction to be consistent with the reference figure.
13. Click Next.
14. Keep the default Phase Delay settings and click Finish to apply the boundary.

Figure 3-19: Primary1 and Secondary1 Boundaries Applied

Second Pair:
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For this procedure, refer to the figure, Primary2 and Secondary2 Boundaries Applied.

1. On the Draw ribbon tab, click Orient to restore the default Trimetric view of the model.
2. Select the face where the Primary boundary is to be applied (labeled and shown without

the green shading in the reference figure). This face is the +Y side of the RhombicCell
object.

3. Right-click in the Modeler window and choose Assign Boundary > Coupled > Primary
from the shortcut menu.

4. Keep the Name as Primary2.
5. Define the U Vector and V Vector direction to be consistent with the reference figure.
6. ClickOK.
7. Select the face where the Secondary boundary is to be applied (the -Y side of the

RhombicCell object).
8. Right-click in the Modeler window and choose Assign Boundary > Coupled > Sec-

ondary.
9. Keep the Name as Secondary2.
10. Choose Primary2 from the Primary Boundary drop-down menu.
11. Define the U Vector and V Vector direction to be consistent with the reference figure.
12. Click Next.
13. Keep the default Phase Delay settings and click Finish to apply the boundary.
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Figure 3-20: Primary2 and Secondary2 Boundaries Applied

14. Clear the selection.

Assign the Perfect E Boundary
You will now assign a Perfect E boundary to the aperture.

1. PressO to enterObject Selectionmode.
2. Select the aperture.
3. From the menu bar, select HFSS > Boundaries > Assign > Perfect E.
4. Leave the Name as PerfE1, Infinite Ground Plane not selected, and clickOK.

The PerfE1 boundary appears on the aperture as shown in following figure:

Figure 3-21: PerfE1 Boundary Applied

5. Clear the selection.

Assign the Floquet Ports
You are all set to assign the Floquet ports to the top and bottom faces of the model.
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1. Press F to return to the Faces selection mode.
2. Select the top face of the model and, on the menu bar, click HFSS > Excitations >

Assign > Port > Floquet Port.

The Floquet Port : General dialog box appears.

3. From the A Direction drop- down menu, select New Vector.

TheMeasure Data and Create Line dialog boxes appear; the latter one instructs you to
draw the vector in the plane of the face.

4. Draw the a vector parallel to the X axis and pointing in the +X direction, as shown in the fig-
ure, FloquetPort1 Vectors.

Note:

Click the corner vertex that lies on the Z-axis first and then, click the corner in the
+X direction to draw the a vector. The Floquet Port : General dialog box
reappears after the second click.

5. From the B Direction drop- down menu, select New Vector.
6. Draw the b vector starting at the same corner vertex as the a vector and ending at the

corner diagonally opposite the endpoint of the a vector, as shown in the following figure:

Figure 3-22: FloquetPort1 Vectors
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The Floquet Port : General dialog box reappears after you click the second vertex.

7. Click Next.
8. ClickModes Calculator for assistance in setting up the port modes.
9. In theMode Table Calculator, specify 20 for the Number of Modes and 20 GHz for the

Frequency, as shown in the following figure. Then, clickOK.

Figure 3-23: Mode Table Calculator

The table in the Fluoquet Port : Modes Setup dialog box now has the following calculated
values:
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Figure 3-24: Calculated Attenuation values

10. Reduce the Number of Modes entry to 14 to eliminate the last six modes from the table.

Note:

The reasoning behind trimming the modes is given in the Omission of Modes with
Large Attenuation section immediately below this procedure.

11. Click Next.

The Floquet Port : Post Processing dialog box appears.

12. Select the Deembed option and specify a Distance of 2 cm.
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Figure 3-25: Post Processing Settings

13. Click Next to advance to the Floquet Port : 3D Refinement dialog box.
14. Click Clear Refinement Selections and then select the Affects Refinement option only

forMode 1.
15. Click Finish.

FloquetPort1 appears under Excitations in the Project Manager.

16. Select the bottom face of the model, and repeat this procedure to set up the second Flo-
quet port.

Note:

The vector directions, modes, and all other options should be identical for Flo-
quetPort2, except that they are applied at the bottom face of the RhombicCell
object. The vectors and modes should be copied automatically from the Flo-
quetPort1 setup. However, you will have to repeat the Deembed and 3D Refine-
ment settings (steps 10 through 14).

Figure 3-26: FloquetPort2 Applied

17. Clear the selection and Save your model.
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Omission of Modes with Large Attenuation:
When defining the Floquet port modes, you trimmed the last six modes from the table. Since the
attenuation is high for modes above the 14th one, the results of those modes would be insig-
nificant. Specifically, for Deembed Distance = 2 cm, the total attenuation from the aperture to the
port = 51.53 db/cm * 2 cm = 103.06 db. This is a very large amount of attenuation. Thus, it is reas-
onable to neglect modes 15 through 20 by eliminating them from the analysis.

Set Up the Analysis

1. On the Simulation ribbon tab, click Setup > Advanced.

The Driven Solution Setup dialog box appears.

2. Under theGeneral tab, enter the settings shown in the following figure:

Figure 3-27: Driven Solution Setup – General Tab

3. Select theMesh/Solution Options tab and, in the Initial Mesh Options section, enter the
settings shown in the following figure:
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Figure 3-28: Driven Solution Setup – Mesh/Solution Options Tab

4. ClickOK.

The Edit Frequency Sweep dialog box appears automatically when you complete the solu-
tion setup for a model that already has at least one port assigned. Keep this dialog box
open. You will define the frequency sweep in the next procedure.

Add Frequency Sweep and Analyze
As a result of adding a solution setup in the previous topic, the Edit Frequency Sweep dialog box
should already be open. Define the sweep as follows:
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1. Under theGeneral tab, enter the settings shown in the following figure:

Figure 3-29: Edit Frequency Sweep Dialog Box – General Tab

2. Select the Interpolation tab and enter the settings shown in following figure:

Figure 3-30: Edit Frequency Sweep Dialog Box – Interpolation Tab

3. Click Advanced Options.

The Interpolating Sweep Advanced Options dialog box appears.

4. Enter the settings shown in the following figure:
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Figure 3-31: Interpolating Sweep Advanced Options

5. Click Select Entries.

The Interpolation Basis Convergence dialog box opens.

6. Ensure that All is selected from both the Entry Selection andMode Selection drop-
down menus.

7. Scroll down until you can see the FloquetPort2:1 row of the table, click in the Flo-
quetPort1:1 column on that row, and chooseON from the drop-down menu:

Frequency Selective Surface Model 3-24

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Floquet Ports

Figure 3-32: Interpolation Basis Convergence Dialog Box

8. ClickOK to close the Interpolation Basis Convergence dialog box,OK to close the Inter-
polating Sweep Advanced Options dialog box, andOK to close the Edit Frequency Sweep
dialog box.

9. On the Simulation ribbon tab, click Validate.

The Validation Check should complete successfully (with no warnings or errors reported).

Note:

For most HFSS projects, do not be alarmed if you see any warnings in theMes-
sage Manager window. Some of these warnings are informational messages
only. They may not always require you to perform any action. However, for this
exercise, theMessage Managermust not display any error or warning mes-
sages; the Validation Check dialog box must show a green check mark at each of
the listed options, indicating that you can analyze the design.

10. Click Close.

11. On the Simulation ribbon tab, click Analyze All.

The solution process begins and should finish in a minute or two, depending on your com-
puter system.
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Evaluate the Results
Now that you've solved the design, it's time to evaluate the results by generating reports (2D
plots). You will also view the port field displays (vector overlays) for several of the Floquet port
modes.

The following topics are covered in this section:

l Phase Transmission vs. Frequency Plot
l S Parameters vs. Frequency Plot
(specifically, Transmission and Reflection vs. Frequency)

l Port Field Displays for Modes

Phase Transmission vs. Frequency

1. On the Results ribbon tab, click Modal Solution Data Report > 2D.

The Report dialog box appears.

2. The Context portion of the dialog box should match the following figure:

Figure 3-33: Context Portion of the Report Dialog Box

3. Under the Trace tab, specify the settings shown in the following image so that the Y axis is
populated with the expression for phase transmission:
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Figure 3-34: Report Dialog Box – Trace Tab

Note:

Keep the default value of X (Freq).

4. Click New Report but leave the Report dialog box open.

HFSS generates the plot for Phase Transmission versus Frequency. See the following fig-
ure, to which annotations have been added. Clearly, from the plot we can see that the
phase angle changes as the waves pass through the FSS cell at varying frequencies.
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Figure 3-35: Phase Transmission vs. Frequency Plot

S Parameters vs. Frequency
In this plot, you will choose the S parameters that represent transmission and reflection versus
frequency.

1. If you did not keep the Report dialog box open from the previous procedure, click

Modal Solution Data Report > 2D on the Results ribbon tab to reopen it.
2. Under the Trace tab of the Report dialog box, S Parameter should still be selected in the

Category list.
3. In theQuantity list, select S(FloquetPort1:1,FloquetPort1:1)) and S(Flo-

quetPort1:1,FloquetPort2:1)).
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Note:

The list of port and mode combinations is long, so choose carefully.

4. In the Function list, select dB.
5. Click New Report and click Close.

The transmission and reflection curves are generated. The figure below has been annot-
ated to clearly indicate the Transmission and Reflection traces:

Figure 3-36: Transmission & Reflection vs. Frequency
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Note:

The point of strongest transmission through the FSS cell and least reflection
occurs at 18 GHz.

Port Field Displays for Modes
1. Return to the Modeler window so that you can review the port field displays for the cal-

culated modes.
2. Under Port Field Display in the Project Manager, there are mode lists for FloquetPort1 and

FloquetPort2. You can expand either port's branch and select a mode to see a vector over-
lay of the port field associated with that mode.

Below are the field displays for the first four modes for each of the two Floquet ports:
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Mode FloquetPort1 FloquetPort2

1

2
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Mode FloquetPort1 FloquetPort2

3

4
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4 - Optionally, Restore Current View
Orientations

You have completed this getting started guide.

If you prefer to use the new view orientations implemented in version 2024 R1 of the Ansys Elec-
tronics Desktop application, clear the Use Legacy View Orientation option as follows:

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is cleared:

3. ClickOK.

The settings in the 3D UI Options dialog box are global. Your choice is retained for all future pro-
gram sessions, projects, and design types that use the 3D Modeler or that produce 3D plots of
results.

Optionally, Restore Current View Orientations 4-1
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You can now save and close this project.

Optionally, Restore Current View Orientations 4-2
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